aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 08:38:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:17 +0200
commit95456c2fc9440bc7aa7657a0360486d6d74336da (patch)
treee2a172dcc676e5c7e3c55ddcc884b914144317f3 /gnu/packages/jupyter.scm
parent2043e7bfc8786a4831247da7095c1e623ad1c4d0 (diff)
downloadguix-95456c2fc9440bc7aa7657a0360486d6d74336da.tar
guix-95456c2fc9440bc7aa7657a0360486d6d74336da.tar.gz
gnu: Add python-jupyterlab-pygments.
* gnu/packages/jupyter.scm (python-jupyterlab-pygments): New variable.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index f826ebd171..955273a0c3 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -184,3 +185,25 @@ Several Jupyter kernels are built upon @code{xeus}, such as @code{xeus-cling},
a kernel for the C++ programming language, and @code{xeus-python}, an
alternative Python kernel for Jupyter.")
(license license:bsd-3)))
+
+(define-public python-jupyterlab-pygments
+ (package
+ (name "python-jupyterlab-pygments")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyterlab_pygments" version))
+ (sha256
+ (base32
+ "0ij14mmnc39nmf84i0av6j9glazjic7wzv1qyhr0j5966s3s1kfg"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #false)) ; there are no tests
+ (propagated-inputs
+ `(("python-pygments" ,python-pygments)))
+ (home-page "https://jupyter.org")
+ (synopsis "Pygments theme using JupyterLab CSS variables")
+ (description
+ "This package contains a syntax coloring theme for pygments making use of
+the JupyterLab CSS variables.")
+ (license license:bsd-3)))