aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 16:23:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:46 -0400
commit7d79d30e3a6911468a2eda0ba1e4d4494b411c01 (patch)
tree94487366eae13cecb45cbf1f2ce68738613c2d83 /gnu/packages/jupyter.scm
parent724731de4c3e8445a347d85891e96c0f341bcc3e (diff)
downloadguix-7d79d30e3a6911468a2eda0ba1e4d4494b411c01.tar
guix-7d79d30e3a6911468a2eda0ba1e4d4494b411c01.tar.gz
gnu: Add python-jupyter-server-mathjax.
* gnu/packages/jupyter.scm (python-jupyter-server-mathjax): New variable.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 175c12496a..18efc9bb8b 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -339,6 +339,39 @@ endpoints—to Jupyter web applications.")
are interactive HTML widgets for Jupyter notebooks and the IPython kernel.")
(license license:bsd-3)))
+(define-public python-jupyter-server-mathjax
+ (package
+ (name "python-jupyter-server-mathjax")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_server_mathjax" version))
+ (sha256
+ (base32 "1cz7grhj9jih9mgw4xk7a4bqy1fwlb1jsawh6ykxnvpydn76rnb4"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "/tmp"
+ (invoke "pytest" "-vv"
+ "--pyargs" "jupyter_server_mathjax"))))))))
+ (propagated-inputs (list python-jupyter-server))
+ (native-inputs
+ (list python-jupyter-server
+ python-jupyter-packaging
+ python-pytest
+ python-pytest-tornasync))
+ (home-page "https://jupyter.org")
+ (synopsis "Jupyter Server extension for serving Mathjax")
+ (description "This package provides a Jupyter Server extension for serving
+Mathjax, the JavaScript display engine for mathematics.")
+ (license license:bsd-3)))
+
(define-public python-nbclient
(package
(name "python-nbclient")