aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-25 15:58:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-25 16:58:40 +0200
commit617bca2ab0b4f57c65873cf3858c6387ea775ab1 (patch)
tree4804e6137275a6e723c5f02ff4455fa43073b065 /gnu/packages/jupyter.scm
parent1b9a0135fb54076f695178eae9f65a6567745898 (diff)
downloadguix-617bca2ab0b4f57c65873cf3858c6387ea775ab1.tar
guix-617bca2ab0b4f57c65873cf3858c6387ea775ab1.tar.gz
gnu: Add python-jupyterlite-sphinx.
* gnu/packages/jupyter.scm (python-jupyterlite-sphinx): New variable. Change-Id: I182c98e0c47d28012882994824232c3473ba3dcd
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 7285afdfd0..87854afd72 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -436,6 +436,28 @@ for building JupyterLite websites, the jupyter-lite CLI, and extension points
for authoring custom addons.")
(license license:bsd-3)))
+(define-public python-jupyterlite-sphinx
+ (package
+ (name "python-jupyterlite-sphinx")
+ (version "0.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyterlite_sphinx" version))
+ (sha256
+ (base32 "05h7zrvsx0xzxlddsqfz1fxdgld66yhn6nxfp4jz20wbx6csrr4v"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-docutils python-jupyter-server
+ python-jupyterlab-server python-jupyterlite-core
+ python-sphinx))
+ (native-inputs (list python-hatchling))
+ (home-page "https://github.com/jupyterlite/jupyterlite")
+ (synopsis "Sphinx extension for deploying JupyterLite")
+ (description "This package provides a Sphinx extension for deploying
+@code{JupyterLite}.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-server-mathjax
(package
(name "python-jupyter-server-mathjax")