aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:46 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:37 +0100
commita0ca88b1a6e1e820fc0513acf37b2e495e36baca (patch)
tree073f2092dc3d2568dd7f36e4a5bc9fb27cf7b100 /gnu/packages/julia-xyz.scm
parentf808ce789da223311bc0416a593ecc1b6edb2248 (diff)
downloadguix-a0ca88b1a6e1e820fc0513acf37b2e495e36baca.tar
guix-a0ca88b1a6e1e820fc0513acf37b2e495e36baca.tar.gz
gnu: Add julia-remotefiles.
* gnu/packages/julia-xyz.scm (julia-remotefiles): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0724977f39..ffbdb2a1a7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5001,6 +5001,31 @@ recursive arrays like arrays of arrays.")
(description "This package provides tools to re-export modules and symbols.")
(license license:expat)))
+(define-public julia-remotefiles
+ (package
+ (name "julia-remotefiles")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/helgee/RemoteFiles.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zpklzpd4ckp7s4wbf93qmq3dyyrx4pzl41x5i9zbiskadhniqnh"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests try to download from Internet.
+ (propagated-inputs
+ (list julia-fileio julia-http))
+ (home-page "https://github.com/helgee/RemoteFiles.jl")
+ (synopsis "Download files from the Internet and keep them up-to-date")
+ (description
+ "This package provides a functionality of files download with cURL, wget or
+@code{HTTP.jl} backends.")
+ (license license:expat)))
+
(define-public julia-referencetests
(package
(name "julia-referencetests")