aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-01-30 12:12:10 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-02-08 09:26:21 +0200
commit96d33bfb354c7c4c957a665a1feae08e45d756de (patch)
treef6a793585f2b538a6f4ecb83ba4012e2533c4f46 /gnu/packages/julia-xyz.scm
parent1973ddbb6c6255c67e256efbaeaccd1dc4587102 (diff)
downloadguix-96d33bfb354c7c4c957a665a1feae08e45d756de.tar
guix-96d33bfb354c7c4c957a665a1feae08e45d756de.tar.gz
gnu: Add julia-cfitsio.
* gnu/packages/julia-xyz.scm (julia-cfitsio): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2e334235a3..02f270b35e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -746,6 +747,36 @@ variables, both with unordered (nominal variables) and ordered categories
(description "This package provides a C-compatible enum for Julia.")
(license license:expat)))
+(define-public julia-cfitsio
+ (package
+ (name "julia-cfitsio")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/CFITSIO.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05bxzzjcc021p3hi092h06r2q7qnvql0xz1alggi83i0pp1mxp6d"))))
+ (build-system julia-build-system)
+ (native-inputs (list julia-aqua))
+ (propagated-inputs (list julia-cfitsio-jll))
+ (home-page "https://github.com/JuliaAstro/CFITSIO.jl")
+ (synopsis "C-style interface to the libcfitsio library")
+ (description "This package provides Julia implementation of C-style
+interface to CFITSIO functions with following features:
+@itemize
+@item Function names closely mirror the C interface (e.g.,
+@code{fits_open_file()}).
+@item Functions operate on @code{FITSFile}, a thin wrapper for fitsfile C
+struct (@code{FITSFile} has concept of \"current HDU\", as in CFITSIO).
+@item Wrapper functions do check the return status from CFITSIO and throw an
+error with the appropriate message.
+@end itemize")
+ (license license:expat)))
+
(define-public julia-chainrules
(package
(name "julia-chainrules")