aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:35:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:55 +0300
commitf7033423d3143373902461ef122a27a485432936 (patch)
treee55c71760c44d08915d8bbaeadde1bfb08471cb9 /gnu/packages/julia-jll.scm
parent2cc2507d0e1d1bc30d4ad755dd1e73e21e8bcd1f (diff)
downloadguix-f7033423d3143373902461ef122a27a485432936.tar
guix-f7033423d3143373902461ef122a27a485432936.tar.gz
gnu: Add julia-xorg-libxinerama-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxinerama-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index e6202dd4a6..9708bd0175 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1891,6 +1891,43 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxi library.")
(license license:expat)))
+(define-public julia-xorg-libxinerama-jll
+ (package
+ (name "julia-xorg-libxinerama-jll")
+ (version "1.1.4+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXinerama_jll.jl")
+ (commit (string-append "Xorg_libXinerama-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jybxbqxd4jc9ka3rk3v5yh8ps2fapdibldr7bymllzw1w2i25rn"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXinerama\"")
+ (string-append "\"" (assoc-ref inputs "libxinerama") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxinerama" ,libxinerama)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libxext-jll" ,julia-xorg-libxext-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXinerama_jll.jl")
+ (synopsis "Libxinerama library wrappers")
+ (description "This package provides a wrapper for the libxinerama library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxrender-jll
(package
(name "julia-xorg-libxrender-jll")