aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 02:23:48 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:30 +0200
commit17527c12e0868f3ccb0ca41b86e382f1ba91009d (patch)
tree37022ec3c3c943dab03575ba28bcfd0a90398833 /gnu/packages/jemalloc.scm
parent7bd24f5bd1ff61a7dc494d62e9fb836c07e516a9 (diff)
downloadguix-17527c12e0868f3ccb0ca41b86e382f1ba91009d.tar
guix-17527c12e0868f3ccb0ca41b86e382f1ba91009d.tar.gz
gnu: Remove jemalloc@4.5.0.
* gnu/packages/jemalloc.scm (jemalloc-4.5.0): Merge with ... (jemalloc): ... this variable. [arguments]: Convert to gexp and remove obsolete "--disable-thp" flag. [inputs]: Add PERL.
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm66
1 files changed, 25 insertions, 41 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 354f07a838..c8e355ccb3 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
+;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,16 +26,17 @@
#:use-module (ice-9 match)
#:use-module ((guix licenses) #:select (bsd-2))
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
#:use-module (guix build-system gnu))
-(define-public jemalloc-4.5.0
+(define-public jemalloc
(package
(name "jemalloc")
- (version "4.5.0")
+ (version "5.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -42,26 +44,29 @@
version "/jemalloc-" version ".tar.bz2"))
(sha256
(base32
- "10373xhpc10pgmai9fkc1z0rs029qlcb3c0qfnvkbwdlcibdh2cl"))))
+ "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-thp-test
- ;; This test does not check if transparent huge pages are supported
- ;; on the system before running the test.
- (lambda _
- (substitute* "Makefile.in"
- (("\\$\\(srcroot\\)test/unit/pages.c \\\\") "\\"))
- #t)))
- #:configure-flags
- '(,@(match (%current-system)
- ((or "i686-linux" "x86_64-linux")
- '())
- ("powerpc-linux"
- (list "--disable-thp" "CPPFLAGS=-maltivec"))
- (_
- (list "--disable-thp"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-thp-test
+ ;; This test does not check if transparent huge pages are supported
+ ;; on the system before running the test.
+ (lambda _
+ (substitute* "Makefile.in"
+ (("\\$\\(srcroot\\)test/unit/pages.c \\\\") "\\")))))
+ #:configure-flags
+ ;; Disable the thread local storage model in jemalloc 5 to prevent
+ ;; shared libraries linked to libjemalloc from crashing on dlopen()
+ ;; https://github.com/jemalloc/jemalloc/issues/937
+ #~'("--disable-initial-exec-tls"
+ #$@(match (%current-system)
+ ("powerpc-linux"
+ (list "CPPFLAGS=-maltivec"))
+ (_
+ '())))))
+ (inputs (list perl))
;; Install the scripts to a separate output to avoid referencing Perl and
;; Bash in the default output, saving ~75 MiB on the closure.
(outputs '("out" "bin"))
@@ -71,24 +76,3 @@
"This library providing a malloc(3) implementation that emphasizes
fragmentation avoidance and scalable concurrency support.")
(license bsd-2)))
-
-(define-public jemalloc
- (package
- (inherit jemalloc-4.5.0)
- (version "5.3.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/jemalloc/jemalloc/releases/download/"
- version "/jemalloc-" version ".tar.bz2"))
- (sha256
- (base32
- "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
- (arguments
- (substitute-keyword-arguments (package-arguments jemalloc-4.5.0)
- ;; Disable the thread local storage model in jemalloc 5 to prevent
- ;; shared libraries linked to libjemalloc from crashing on dlopen()
- ;; https://github.com/jemalloc/jemalloc/issues/937
- ((#:configure-flags base-configure-flags '())
- `(cons "--disable-initial-exec-tls" ,base-configure-flags))))
- (inputs (list perl))))