aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-11-02 07:50:11 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-11-09 19:08:51 +0100
commit14e01e313da2d0650d4501233e4a10787df213f1 (patch)
tree7882c5001e2a0c78f7d1a669e9a3bc7e489762b8 /gnu/packages/java.scm
parent00ec39a4e4807957161ae16db04d5d9f75c19b2f (diff)
downloadguix-14e01e313da2d0650d4501233e4a10787df213f1.tar
guix-14e01e313da2d0650d4501233e4a10787df213f1.tar.gz
gnu: Add java-jakarta-json.
* gnu/packages/java.scm (java-jakarta-json): New variable. Change-Id: I2c123710f9d31bf71e8fb86ff0d336b6fcfa9674
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 65d8f57508..b7137386c3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13655,6 +13655,33 @@ and allows building a Java object model for JSON text using API classes
parse, generate, transform and query) JSON messages. This package contains
a reference implementation of that API.")))
+(define-public java-jakarta-json
+ (package
+ (name "java-jakarta-json")
+ (version "2.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jakartaee/jsonp-api")
+ (commit (string-append version "-RELEASE"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q600harqfhlf763l75j4fx7ai7ybp7ga06aiky2a2hg8mhz0s5f"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "jakarta-json.jar"
+ #:source-dir "api/src/main/java"
+ #:tests? #f; no tests
+ #:jdk ,openjdk11))
+ (home-page "https://github.com/jakartaee/jsonp-api")
+ (synopsis "Portable API for JSON handling in Java")
+ (description "This project contains API and Compatible Implementation of
+Jakarta JSON Processing specification. Jakarta JSON Processing provides
+portable APIs to parse, generate, transform, and query JSON documents.")
+ ;; with classpath exception
+ (license license:epl2.0)))
+
(define-public java-xmp
(package
(name "java-xmp")