aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 10:08:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 10:23:25 -0500
commitb5e300f9c15640090c82225ca13c25bd54eb0ed4 (patch)
tree2b0fd5389132dfc5355740f91e0d127a4fa93d48 /gnu/packages/jami.scm
parenta083a9b512b695f5a5c7bca7d5a19dda97bd33b9 (diff)
downloadguix-b5e300f9c15640090c82225ca13c25bd54eb0ed4.tar
guix-b5e300f9c15640090c82225ca13c25bd54eb0ed4.tar.gz
gnu: jami: Update to 20230206.0.
* gnu/packages/jami.scm (jami): Update to 20230206.0. (%jami-version): Update version. (%jami-sources): Adjust URI. Streamline snippet. (jami-apply-custom-patches): Use a wildcard to match the top-level directory, which now includes the version. (%ffmpeg-default-configure-flags): Adjust URL in top comment. * gnu/packages/patches/jami-libjami-headers-search.patch: Adjust file names for new tarball layout.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm47
1 files changed, 19 insertions, 28 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index b74cdff0c7..e425a6547a 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2019, 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
-;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,31 +69,24 @@
#:use-module (guix packages)
#:use-module (guix utils))
-(define %jami-version "20221220.0956.79e1207")
+(define %jami-version "20230206.0")
(define %jami-sources
;; Return an origin object of the tarball release sources archive of the
;; Jami project.
(origin
(method url-fetch)
- (uri (string-append "https://dl.jami.net/release/tarballs/jami_"
- %jami-version
- ".tar.gz"))
+ (uri (string-append "https://dl.jami.net/release/tarballs/jami-"
+ %jami-version ".tar.gz"))
(modules '((guix build utils)))
(snippet
- `(begin
- ;; Delete multiple MiBs of bundled tarballs. The contrib directory
- ;; contains the custom patches for pjproject and other libraries used
- ;; by Jami.
- (delete-file-recursively "daemon/contrib/tarballs")
- ;; Remove the git submodule directories of unused Jami clients.
- (for-each delete-file-recursively '("client-android"
- "client-ios"
- "client-macosx"
- "plugins"))))
+ ;; Delete multiple MiBs of bundled tarballs. The daemon/contrib
+ ;; directory contains the custom patches for pjproject and other
+ ;; libraries used by Jami.
+ '(delete-file-recursively "daemon/contrib/tarballs"))
(sha256
(base32
- "0g5709rmb9944s0ij9g4pm1b871f5z0s5nawvm10z14wx3y1np8m"))
+ "1fx7c6q8j0x3q8cgzzd4kpsw3npqggsi1n493cv1jg7v5d01d3jz"))
(patches (search-patches "jami-disable-integration-tests.patch"
"jami-libjami-headers-search.patch"))))
@@ -107,14 +100,12 @@
(invoke "tar" "-xvf" #$%jami-sources
"-C" patches-directory
"--strip-components=5"
- (string-append "jami-project/daemon/contrib/src/"
- dep-name))
- (for-each
- (lambda (file)
- (invoke "patch" "--force" "--ignore-whitespace" "-p1" "-i"
- (string-append patches-directory "/"
- file ".patch")))
- patches))))
+ "--wildcards"
+ (string-append "jami-*/daemon/contrib/src/" dep-name))
+ (for-each (lambda (f)
+ (invoke "patch" "--force" "--ignore-whitespace" "-p1" "-i"
+ (string-append patches-directory "/" f ".patch")))
+ patches))))
(define-public pjproject-jami
(let ((commit "513a3f14c44b2c2652f9219ec20dea64b236b713")
@@ -153,10 +144,10 @@
'("0009-add-config-site")))))))))))
;; The following variables are configure flags used by ffmpeg-jami. They're
-;; from the jami-project/daemon/contrib/src/ffmpeg/rules.mak file. We try to
-;; keep it as close to the official Jami package as possible, to provide all
-;; the codecs and extra features that are expected (see:
-;; https://review.jami.net/plugins/gitiles/ring-daemon/+/refs/heads/master/contrib/src/ffmpeg/rules.mak)
+;; from the jami/daemon/contrib/src/ffmpeg/rules.mak file. We try to keep it
+;; as close to the official Jami package as possible, to provide all the
+;; codecs and extra features that are expected (see:
+;; https://review.jami.net/plugins/gitiles/jami-daemon/+/refs/heads/master/contrib/src/ffmpeg/rules.mak)
(define %ffmpeg-default-configure-flags
'("--disable-everything"
"--enable-zlib"