aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/installers.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-08-02 17:23:05 +0200
committer宋文武 <iyzsong@member.fsf.org>2022-08-03 14:23:00 +0800
commite2ad0b0f8b9cdea88211827b40a5b46aa4d9f062 (patch)
treedad4d2073a4532ddd1a4da1467078235bdfb5166 /gnu/packages/installers.scm
parentcb14d802aef0aaa475147e0a5cc36ff71e631a62 (diff)
downloadguix-e2ad0b0f8b9cdea88211827b40a5b46aa4d9f062.tar
guix-e2ad0b0f8b9cdea88211827b40a5b46aa4d9f062.tar.gz
gnu: nsis: Update to 3.08.
* gnu/packages/patches/nsis-source-date-epoch.patch: Drop this patch. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/patches/nsis-env-passthru.patch: Adjust the patch. * gnu/packages/installers.scm (make-nsis): Update to 3.08. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/installers.scm')
-rw-r--r--gnu/packages/installers.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/installers.scm b/gnu/packages/installers.scm
index 01ad03e6af..30cd0e4e6c 100644
--- a/gnu/packages/installers.scm
+++ b/gnu/packages/installers.scm
@@ -34,16 +34,15 @@
(xgcc (cross-gcc triplet #:libc xlibc)))
(package
(name (string-append "nsis-" machine))
- (version "3.05")
+ (version "3.08")
(source (origin
(method url-fetch)
(uri (string-append "http://prdownloads.sourceforge.net/nsis/nsis-"
version "-src.tar.bz2"))
(sha256
(base32
- "1sbwx5vzpddharkb7nj4q5z3i5fbg4lan63ng738cw4hmc4v7qdn"))
- (patches (search-patches "nsis-env-passthru.patch"
- "nsis-source-date-epoch.patch"))))
+ "11qy1n1qdcqwal9hn8cmzm7gxjdyx7by6w14rfz2l646afnp0lm8"))
+ (patches (search-patches "nsis-env-passthru.patch"))))
(build-system scons-build-system)
(native-inputs `(("xgcc" ,xgcc)
("xbinutils" ,xbinutils)
@@ -125,7 +124,7 @@
(lambda _
;; NSIS target detection is screwed up, manually change
;; it ourselves
- (substitute* "Source/build.cpp" (("m_target_type=TARGET_X86ANSI")
+ (substitute* "Source/build.cpp" (("m_target_type=TARGET_X86UNICODE")
(string-append "m_target_type=" ,nsis-target-type))))))))
(home-page "https://nsis.sourceforge.io/Main_Page")
(synopsis "System to create Windows installers")