aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorSaku Laesvuori via Guix-patches via <guix-patches@gnu.org>2023-07-20 21:37:15 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:30 +0200
commite77aef7f74caa82baf393f25a0722f444d19cc37 (patch)
tree6992081698ddaff8079b88a5eb93fac827852ca7 /gnu/packages/imagemagick.scm
parentf40553702db7f633f4966ae29655c32ee224cd53 (diff)
downloadguix-e77aef7f74caa82baf393f25a0722f444d19cc37.tar
guix-e77aef7f74caa82baf393f25a0722f444d19cc37.tar.gz
gnu: imagemagick: Update to 6.9.12-91.
* gnu/packages/imagemagick.scm (imagemagick) (imagemagick/stable): Update to 6.9.12-91. [patches]: Remove upstreamed patches. Add patch for fixing tests. [arguments]: Enable tests. * gnu/packages/patches/imagemagick-Fix-tests.patch: New file. gnu/packages/patches/imagemagick-CVE-2020-27829.patch: Delete file. * gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch: Likewise. * gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch: Likewise. * gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I4c554abb1e5592590c3af8c57d9113d90de3f194
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm34
1 files changed, 12 insertions, 22 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 4af2f95b65..cf6b6d5135 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -65,19 +65,16 @@
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-4")
+ (version "6.9.12-91")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://imagemagick/ImageMagick-"
- version ".tar.xz"))
- (sha256
- (base32
- "1pkwij76yz7vd5grl6520pgpa912qb6kh34qamx4zfndwcx6cf6b"))
- (patches
- (search-patches "imagemagick-ReadDCMImage-fix.patch"
- "imagemagick-ReadDCMPixels-fix.patch"
- "imagemagick-WriteTHUMBNAILImage-fix.patch"
- "imagemagick-CVE-2020-27829.patch"))))
+ (method url-fetch)
+ (uri (string-append "mirror://imagemagick/ImageMagick-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
+ (patches
+ (search-patches "imagemagick-fix-tests.patch"))))
(build-system gnu-build-system)
(arguments
(list
@@ -85,10 +82,6 @@
;; Do not embed the build date in binaries.
"--enable-reproducible-build")
-
- ;; FIXME: The test suite succeeded before version 6.9.6-2.
- ;; Try enabling it again with newer releases.
- #:tests? #f
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pre-build
@@ -153,19 +146,16 @@ text, lines, polygons, ellipses and Bézier curves.")
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-4")
+ (version "6.9.12-91")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1pkwij76yz7vd5grl6520pgpa912qb6kh34qamx4zfndwcx6cf6b"))
+ "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
(patches
- (search-patches "imagemagick-ReadDCMImage-fix.patch"
- "imagemagick-ReadDCMPixels-fix.patch"
- "imagemagick-WriteTHUMBNAILImage-fix.patch"
- "imagemagick-CVE-2020-27829.patch"))))))
+ (search-patches "imagemagick-fix-tests.patch"))))))
(define-public perl-image-magick
(package