aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorCairn <cairn@pm.me>2023-06-15 17:52:29 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-24 16:56:13 +0200
commitf9f6f8d25ab00e41448ae6f89a42d63fd4a35baa (patch)
treeffe32dc72573a39925b66e9ae170fceda0b03fdc /gnu/packages/image-processing.scm
parentbf2b18250cbee10d5a73fa7175054f2cafa40212 (diff)
downloadguix-f9f6f8d25ab00e41448ae6f89a42d63fd4a35baa.tar
guix-f9f6f8d25ab00e41448ae6f89a42d63fd4a35baa.tar.gz
gnu: Add libansilove.
* gnu/packages/image-processing.scm (libansilove): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index f2ea6534f4..7eaa0eed67 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2023 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages game-development)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gd)
#:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gimp)
@@ -1735,3 +1737,29 @@ can call the CharLS codec and pass it images (sometimes called raster bitmaps),
to have them encoded to JPEG-LS, or JPEG-LS streams, which CharLS will decode
to images.")
(license license:bsd-3)))
+
+(define-public libansilove
+ (package
+ (name "libansilove")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ansilove/libansilove")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "169njlck4a2bmf1kmjas1w594hyda543ykdnwg7fwkviij39l9z6"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; No tests included
+ (native-inputs
+ (list gd))
+ (home-page "https://www.ansilove.org/")
+ (synopsis "Library for converting ANSI, ASCII, and other formats to PNG")
+ (description
+ "libansilove is a library for converting artscene file types to PNG images,
+including ANSI (.ANS) and many others. The library primarily serves to support
+the ansilove tool.")
+ (license license:bsd-2)))