aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-09-12 19:25:45 +0000
committerChristopher Baines <mail@cbaines.net>2022-09-17 19:09:45 +0200
commitc00e1c87f219ab9947204af53afff6ccf812fa91 (patch)
treef0b1fc59c84004e6b650a7da546c5b3a5ab061bc /gnu/packages/image-processing.scm
parent229425fa5360391e08292fdb752af3f3e1c3e117 (diff)
downloadguix-c00e1c87f219ab9947204af53afff6ccf812fa91.tar
guix-c00e1c87f219ab9947204af53afff6ccf812fa91.tar.gz
gnu: vtk: Use system libHaru.
* gnu/packages/image-processing.scm (vtk)[snippet]: Delete bundled libHaru and patch VTK for newer libHaru. Reindent and remove trailing boolean. [arguments]: Specify external libHaru in configure flags. [inputs]: Add libharu. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index aa8efd97c6..a8f40c4454 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -324,14 +324,18 @@ many popular formats.")
(snippet
'(begin
(for-each
- (lambda (dir)
- (delete-file-recursively
- (string-append "ThirdParty/" dir "/vtk" dir)))
- ;; pugixml depended upon unconditionally
- '("doubleconversion" "eigen" "expat" "freetype" "gl2ps"
- "glew" "hdf5" "jpeg" "jsoncpp" "libproj" "libxml2" "lz4"
- "netcdf" "ogg" "png" "sqlite" "theora" "tiff" "zlib"))
- #t))))
+ (lambda (dir)
+ (delete-file-recursively
+ (string-append "ThirdParty/" dir "/vtk" dir)))
+ ;; pugixml depended upon unconditionally
+ '("doubleconversion" "eigen" "expat" "freetype" "gl2ps"
+ "glew" "hdf5" "jpeg" "jsoncpp" "libharu" "libproj"
+ "libxml2" "lz4" "netcdf" "ogg" "png" "sqlite" "theora"
+ "tiff" "zlib"))
+ (substitute* "IO/ExportPDF/vtkPDFContextDevice2D.cxx"
+ (("\\bHPDF_UINT16 (noPen|dash|dot|denseDot|dashDot|dashDotDot)\\b"
+ _ var)
+ (string-append "HPDF_REAL " var)))))))
(properties `((release-monitoring-url . "https://vtk.org/download/")))
(build-system cmake-build-system)
(arguments
@@ -348,6 +352,7 @@ many popular formats.")
"-DVTK_MODULE_USE_EXTERNAL_VTK_hdf5=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_jpeg=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_jsoncpp=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_libharu=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_libproj=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_libxml2=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_lz4=ON"
@@ -381,6 +386,7 @@ many popular formats.")
glew
glu
hdf5
+ libharu
libjpeg-turbo
jsoncpp
libtheora