aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 11:45:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 15:15:38 -0500
commitd5078bd193db5e82c63e67a7fe8996f13f201fce (patch)
treeeeac0a1e7ee991efdfe1250cb99cb04001a147b4 /gnu/packages/ibus.scm
parent31dac1f0fb3d85dd4d3e57a878b87216d4ca3e40 (diff)
downloadguix-d5078bd193db5e82c63e67a7fe8996f13f201fce.tar
guix-d5078bd193db5e82c63e67a7fe8996f13f201fce.tar.gz
gnu: ibus-minimal: Move Python support to ibus.
This reduces the size of ibus-minimal from 1446.7 MiB to 1222.3 MiB. * gnu/packages/ibus.scm (ibus-minimal): Remove "--enable-python-library" flag. [phases] {wrap-with-additional-paths}: Do not wrap GUIX_PYTHONPATH. [inputs]: Move python-pygobject, python and python-dbus to... (ibus) [inputs]: ... here. [arguments]: Add --enable-python-library configure flag and override wrap-with-additional-paths phase.
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm38
1 files changed, 25 insertions, 13 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 4c45671acc..234f17213a 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,8 +90,7 @@
(outputs '("out" "doc"))
(arguments
(list
- #:configure-flags #~(list "--enable-python-library"
- "--enable-gtk-doc"
+ #:configure-flags #~(list "--enable-gtk-doc"
"--enable-memconf"
(string-append
"--with-unicode-emoji-dir="
@@ -185,10 +184,8 @@
(string-append #$output:doc "/share/gtk-doc"))))
(add-after 'wrap-program 'wrap-with-additional-paths
(lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
- ;; GI_TYPELIB_PATH.
+ ;; Make sure 'ibus-setup' runs with the correct GI_TYPELIB_PATH.
(wrap-program (search-input-file outputs "bin/ibus-setup")
- `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix
(,(getenv "GI_TYPELIB_PATH")
,(string-append #$output "/lib/girepository-1.0")))))))))
@@ -205,9 +202,6 @@
libx11
libxkbcommon
libxtst
- python-pygobject
- python
- python-dbus
setxkbmap
ucd
unicode-cldr-common
@@ -243,11 +237,29 @@ may also simplify input method development.")
(define-public ibus
(package/inherit ibus-minimal
- (arguments (substitute-keyword-arguments (package-arguments ibus-minimal)
- ((#:configure-flags flags)
- #~(cons* "--enable-gtk4" #$flags))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ibus-minimal)
+ ((#:configure-flags flags)
+ #~(cons* "--enable-gtk4"
+ "--enable-python-library"
+ #$flags))
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (replace 'wrap-with-additional-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure 'ibus-setup' runs with the correct
+ ;; GUIX_PYTHONPATH and GI_TYPELIB_PATH.
+ (wrap-program (search-input-file outputs "bin/ibus-setup")
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH")
+ ,(string-append #$output "/lib/girepository-1.0"))))))))))
(inputs (modify-inputs (package-inputs ibus-minimal)
- (prepend gtk pango-next)))
+ (prepend gtk
+ pango-next
+ python
+ python-dbus
+ python-pygobject)))
(properties (alist-delete 'hidden? (package-properties ibus-minimal)))))
(define-public ibus-libpinyin