aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/ibus.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
downloadguix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar
guix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar.gz
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 2143624b92..de15587cb0 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -875,6 +876,13 @@ hanja dictionary and small hangul character classification.")
(substitute* "meson.build"
(("update_desktop_database: true")
"update_desktop_database: false"))))
+ (add-after 'set-paths 'add-install-to-pythonpath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (ibus-stt-dir (string-append out "/share/ibus-stt")))
+ (setenv "GUIX_PYTHONPATH"
+ (string-append ibus-stt-dir ":"
+ (getenv "GUIX_PYTHONPATH"))))))
(add-after 'install 'wrap-with-additional-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'ibus-{setup,engine}-stt' find the gst-vosk plugin
@@ -886,23 +894,14 @@ hanja dictionary and small hangul character classification.")
(,(string-append (assoc-ref inputs "gst-vosk")
"/lib/gstreamer-1.0")
,(getenv "GST_PLUGIN_SYSTEM_PATH")))
- `("GUIX_PYTHONPATH" ":" prefix
- (,(getenv "GUIX_PYTHONPATH")
- ,(string-append (assoc-ref inputs "ibus")
- "/lib/girepository-1.0")
- ,(string-append (assoc-ref outputs "out")
- "/share/ibus-stt")))
- `("GI_TYPELIB_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "ibus")
- "/lib/girepository-1.0")
- ,(string-append (assoc-ref outputs "out")
- "/share/ibus-stt")))))
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))
(list (string-append out "/libexec/ibus-engine-stt")
(string-append out "/libexec/ibus-setup-stt")))))))))
(inputs
- (list desktop-file-utils
- (list glib "bin")
- gobject-introspection
+ (list bash-minimal
gst-vosk
gstreamer
gtk
@@ -912,7 +911,11 @@ hanja dictionary and small hangul character classification.")
python-babel
python-pygobject))
(native-inputs
- (list gettext-minimal libxml2 pkg-config))
+ (list desktop-file-utils
+ gettext-minimal
+ (list glib "bin")
+ gobject-introspection
+ libxml2 pkg-config))
(home-page "https://github.com/PhilippeRo/IBus-Speech-To-Text")
(synopsis "Speech to text IBus engine using VOSK")
(description "This Input Method uses VOSK for voice recognition and allows