aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-07-28 21:51:59 +0900
committer宋文武 <iyzsong@member.fsf.org>2023-08-03 18:30:45 +0800
commit782cf09b84bc72514e89d783460ea98bc353bf6a (patch)
treeac42bd4dedd6f263808ac7f516c852737aea0596 /gnu/packages/ibus.scm
parent4eeb35595b05d7a3c83de1f901b3edffcafe9df5 (diff)
downloadguix-782cf09b84bc72514e89d783460ea98bc353bf6a.tar
guix-782cf09b84bc72514e89d783460ea98bc353bf6a.tar.gz
gnu: Add ibus-table-others.
* gnu/packages/ibus.scm (ibus-table-others): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 4d99ef39f6..c3310ec2a3 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -950,6 +950,55 @@ hanja dictionary and small hangul character classification.")
IBus.")
(license lgpl2.1+)))
+(define-public ibus-table-others
+ (package
+ (name "ibus-table-others")
+ (version "1.3.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/moebiuscurve/ibus-table-others/releases/"
+ "download/" version "/ibus-table-others-" version ".tar.gz"))
+ (sha256
+ (base32 "0vllwrjlgcvdjhs7nrg45hfvnivnfhrc05r6rhw8m0c41layl9jg"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda _
+ (setenv "HOME" (getcwd))))))) ; db written in $HOME
+ (native-inputs (list pkg-config python))
+ (inputs (list ibus ibus-table))
+ (home-page "https://github.com/moebiuscurve/ibus-table-others")
+ (synopsis "Various table-based input methods for IBus")
+ (description
+ "@code{ibus-table-others} provides the following input methods on
+IBus-Table on IBus framework:
+
+@itemize
+@item CNS11643
+@item Compose
+@item Emoji
+@item IPA-X-SAMPA
+@item LaTex
+@item Mathwriter
+@item Mongol bichig
+@item RussianTraditional
+@item Telex
+@item Thai
+@item Translit
+@item Ua-Translit
+@item Viqr
+@item VNI
+@item Yawerty
+@end itemize")
+ ;; GPL-3.0-or-later: vni, ipa-x-sampa, telex
+ ;; WTFPL: mongol_bichig
+ ;; LGPL-2.1-or-later: others
+ (license (list lgpl2.1+ gpl3+ wtfpl2))))
+
(define-public ibus-speech-to-text
(package
(name "ibus-speech-to-text")