aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-14 11:47:46 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-14 11:53:12 +0100
commita041bbb4bf98cce72b14c554369fc56eeacc2f5d (patch)
treeb1ee0db99de6d9331726522ccee726a22941da61 /gnu/packages/hurd.scm
parentddbfef2e956effdb640712a1829206f2b496f6c2 (diff)
downloadguix-a041bbb4bf98cce72b14c554369fc56eeacc2f5d.tar
guix-a041bbb4bf98cce72b14c554369fc56eeacc2f5d.tar.gz
Revert "gnu: mig: Update to 1.8+git20230520."
As noted in the comment, I think using git-fetch caused problems computing derivaations for i586-linux (Guix would just use more and more memory). This reverts commit 999a6ac0cfd9339e138007ed9e4e544a55e92e3e.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7e788d398d..0e47a954d7 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -91,20 +91,24 @@
(define-public mig
(package
(name "mig")
- (version "1.8+git20230520")
+ (version "1.8+git20220827")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/hurd/mig.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ ;; XXX: Version 2.35 of glibc can only be built with an
+ ;; unreleased version of MiG:
+ ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
+ ;; It cannot be fetched from Git though, as the extra dependency
+ ;; on Autoconf/Automake would complicate bootstrapping.
+ (uri (string-append "mirror://gnu/guix/mirror/mig-"
+ version ".tar.gz"))
(sha256
(base32
- "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
+ "163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
+ (patches (search-patches "mig-cpu.h-generation.patch"))))
(build-system gnu-build-system)
;; Flex is needed both at build and run time.
(inputs (list gnumach-headers flex))
- (native-inputs (list autoconf automake flex bison))
+ (native-inputs (list flex bison))
(arguments
(list #:tests? #f
#:phases