aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haxe.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-27 22:50:25 -0400
committerLeo Famulari <leo@famulari.name>2023-04-30 04:47:19 -0400
commit15172a5c1e8290c0105583db41dcaff7dcf60a31 (patch)
tree1b8cb1f6c58118fe525d56ae092a5ebd51213798 /gnu/packages/haxe.scm
parent3b5b6683037dfb8f02d04ad3e6c2f04062db9a16 (diff)
downloadguix-15172a5c1e8290c0105583db41dcaff7dcf60a31.tar
guix-15172a5c1e8290c0105583db41dcaff7dcf60a31.tar.gz
gnu: neko: Make sure not to keep a store reference to HTTPD.
* gnu/packages/haxe.scm (neko): Move httpd ... [native-inputs]: ... to here. [arguments]: Forbid keeping a reference to httpd.
Diffstat (limited to 'gnu/packages/haxe.scm')
-rw-r--r--gnu/packages/haxe.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index dbe8b2c19e..e4ed5f6792 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -66,7 +66,8 @@
(base32 "1xgw646pghsjjbzd8qlaq17vq96swlrazpivrvyrhdj36vb3sci3"))))
(build-system cmake-build-system)
(arguments
- (list #:phases
+ (list #:disallowed-references (list httpd)
+ #:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'prefix
(lambda _
@@ -76,7 +77,6 @@
(inputs (list apr
apr-util
gtk+-2
- httpd
libgc
mbedtls-apache
mysql
@@ -84,7 +84,9 @@
pcre
sqlite
zlib))
- (native-inputs (list git pkg-config)) ; git for source_archive and applying patch
+ (native-inputs (list httpd
+ git ; git for source_archive and applying patch
+ pkg-config))
(home-page "https://nekovm.org/")
(synopsis "High-level dynamically typed programming language and virtual
machine")