aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 13:36:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:41 +0100
commitf941a52a14a69b69414a3d6b8487676cfe5cbb58 (patch)
treec4500cb73216d206856fba6709fa0726cc9c1041 /gnu/packages/haskell.scm
parent183d1b1aaf5871d6b048176f9aebb1b2aadd28c6 (diff)
downloadguix-f941a52a14a69b69414a3d6b8487676cfe5cbb58.tar
guix-f941a52a14a69b69414a3d6b8487676cfe5cbb58.tar.gz
gnu: Add ghc-text-binary.
* gnu/packages/haskell.scm (ghc-text-binary): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d0472b0105..ac735ca9ea 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1963,6 +1963,29 @@ capabilities that are optimized for performance critical use, both
in terms of large data quantities and high speed.")
(license license:bsd-3)))
+(define-public ghc-text-binary
+ (package
+ (name "ghc-text-binary")
+ (version "0.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "text-binary/text-binary-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18gl10pwg3qwsk0za3c70j4n6a9129wwf1b7d3a461h816yv55xn"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-text" ,ghc-text)))
+ (home-page "https://github.com/kawu/text-binary")
+ (synopsis "Binary instances for text types")
+ (description
+ "This package provides a compatibility layer providing @code{Binary}
+instances for strict and lazy text types for versions older than 1.2.1 of the
+text package.")
+ (license license:bsd-2)))
+
(define-public ghc-strict
(package
(name "ghc-strict")