aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-22 10:32:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-23 16:37:34 +0300
commit279563ffe8cdf16b94603706e32c94d1bdc169ac (patch)
tree62845bd666f1c7bc4a515874154dbb6df59ac5ed /gnu/packages/haskell.scm
parentab8c83dd48c00467503aa33ef68537a85d5b491e (diff)
downloadguix-279563ffe8cdf16b94603706e32c94d1bdc169ac.tar
guix-279563ffe8cdf16b94603706e32c94d1bdc169ac.tar.gz
gnu: ghc-8.6: Rewrite using G-exps.
* gnu/packages/haskell.scm (ghc-8.6)[arguments]: Rewrite using g-exps. Remove trailing #t from phases.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fcad88f240..8c0cc48ef5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -769,10 +769,10 @@ interactive environment for the functional language Haskell.")
(arguments
(substitute-keyword-arguments (package-arguments ghc-8.4)
((#:make-flags make-flags ''())
- `(cons "EXTRA_RUNTEST_OPTS=--skip-perf-tests"
- ,make-flags))
+ #~(cons "EXTRA_RUNTEST_OPTS=--skip-perf-tests"
+ #$make-flags))
((#:phases phases '%standard-phases)
- `(modify-phases ,phases
+ #~(modify-phases #$phases
(add-after 'install 'remove-unnecessary-references
(lambda* (#:key outputs #:allow-other-keys)
(substitute* (find-files (string-append (assoc-ref outputs "out") "/lib/")
@@ -797,8 +797,7 @@ interactive environment for the functional language Haskell.")
(new (string-append out subdir)))
(mkdir-p (dirname new))
(rename-file haddock-file new)))
- (find-files doc "\\.haddock$")))
- #t))
+ (find-files doc "\\.haddock$")))))
(add-after 'unpack-testsuite 'skip-tests
(lambda _
;; These two tests refer to the root user, which doesn't exist
@@ -806,8 +805,7 @@ interactive environment for the functional language Haskell.")
(substitute* "libraries/unix/tests/all.T"
(("^test\\('T8108'") "# guix skipped: test('T8108'"))
(substitute* "libraries/unix/tests/libposix/all.T"
- (("^test\\('posix010'") "# guix skipped: test('posix010'"))
- #t))))))
+ (("^test\\('posix010'") "# guix skipped: test('posix010'"))))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")
(files (list