aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-28 08:30:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:22 +0200
commit1d13003aa9ea35f506546e66fd26383aef3211bf (patch)
tree3790c764afaa148c14ec8f2705a51fcda5d1e8e7 /gnu/packages/haskell.scm
parent576b7dd5083827dd83b45749a6e9b983a20512c9 (diff)
downloadguix-1d13003aa9ea35f506546e66fd26383aef3211bf.tar
guix-1d13003aa9ea35f506546e66fd26383aef3211bf.tar.gz
gnu: Add ghc-weigh.
* gnu/packages/haskell.scm (ghc-weigh): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bcf0b83a04..4be0290825 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10557,4 +10557,26 @@ expose it from another module in the hierarchy.
@end itemize")
(license license:expat)))
+(define-public ghc-weigh
+ (package
+ (name "ghc-weigh")
+ (version "0.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/weigh/"
+ "weigh-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zw2a997gxgdzqmd7j730kxgynzmjvvlkw84dajmfzf1v9pbij7x"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-split" ,ghc-split)
+ ("ghc-temporary" ,ghc-temporary)))
+ (home-page "https://github.com/fpco/weigh#readme")
+ (synopsis "Measure allocations of a Haskell functions/values")
+ (description "This package provides tools to measure the memory usage of a
+Haskell value or function.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here