aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:33:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commit14e9a3971714365136bca777465771066f5afadd (patch)
treeaae614c39f6605ef37a0941bfdb5c0fc340cca5e /gnu/packages/haskell.scm
parent8045d84d72b925bdd2ca099f4e7a6c25cb63e1e1 (diff)
downloadguix-14e9a3971714365136bca777465771066f5afadd.tar
guix-14e9a3971714365136bca777465771066f5afadd.tar.gz
gnu: Add ghc-skylighting.
* gnu/packages/haskell.scm (ghc-skylighting): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b3ba4af685..37b5417a48 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5704,6 +5704,50 @@ needs. It provides a very simple API to create sockets to a destination with
the choice of SSL/TLS, and SOCKS.")
(license license:bsd-3)))
+(define-public ghc-skylighting
+ (package
+ (name "ghc-skylighting")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/skylighting-"
+ version "/skylighting-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0l5lhhqqlfaq1fs7pn3n3b25kmazk8p4ahwvhagbrhcbm5hsigdg"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-colour" ,ghc-colour)
+ ("ghc-diff" ,ghc-diff)
+ ("ghc-hxt" ,ghc-hxt)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-pretty-show" ,ghc-pretty-show)
+ ("ghc-regex-pcre-builtin" ,ghc-regex-pcre-builtin)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-text" ,ghc-text)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/skylighting")
+ (synopsis "Syntax highlighting library")
+ (description "Skylighting is a syntax highlighting library with support
+for over one hundred languages. It derives its tokenizers from XML syntax
+definitions used by KDE's @code{KSyntaxHighlighting} framework, so any syntax
+supported by that framework can be added. An optional command-line program is
+provided. Skylighting is intended to be the successor to highlighting-kate.")
+ (license license:gpl2)))
+
(define-public ghc-doctemplates
(package
(name "ghc-doctemplates")