aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:44 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:21 +0200
commitf3a180296abc97f0a05a5526ed1838332b991918 (patch)
tree2247831ca9826495ef217f286118cc434ec47ab4 /gnu/packages/haskell-xyz.scm
parente2fde26c92daa81670fe26c656f915b1d7806844 (diff)
downloadguix-f3a180296abc97f0a05a5526ed1838332b991918.tar
guix-f3a180296abc97f0a05a5526ed1838332b991918.tar.gz
gnu: Add ghc-indexed-profunctors.
* gnu/packages/haskell-xyz.scm (ghc-indexed-profunctors): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 98b068dcc6..9e8bed6016 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9232,6 +9232,26 @@ API.")
(description "This library provides profunctors for Haskell.")
(license license:bsd-3)))
+(define-public ghc-indexed-profunctors
+ (package
+ (name "ghc-indexed-profunctors")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "indexed-profunctors" version))
+ (sha256
+ (base32
+ "1cbccbvrx73drr1jf3yyw0rp1mcfv3jc1rvdcby5xxx4ja543fjs"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "indexed-profunctors")))
+ (home-page "http://hackage.haskell.org/package/indexed-profunctors")
+ (synopsis "Utilities for indexed profunctors")
+ (description
+ "This package contains basic definitions related to indexed profunctors. These
+are primarily intended as internal utilities to support the @code{optics} and
+@code{generic-lens} package families.")
+ (license license:bsd-3)))
+
(define-public ghc-project-template
(package
(name "ghc-project-template")