aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:50 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:22 +0200
commitc72ccc35ee5e9f70a3f5c337ef7362a5bf6d6b75 (patch)
tree934761b705b41c568607f34845d571d3e796830c /gnu/packages/haskell-xyz.scm
parent045361dd057e1836f7dae952a0f7ba983cff2d5a (diff)
downloadguix-c72ccc35ee5e9f70a3f5c337ef7362a5bf6d6b75.tar
guix-c72ccc35ee5e9f70a3f5c337ef7362a5bf6d6b75.tar.gz
gnu: Add ghc-exception-transformers.
* gnu/packages/haskell-xyz.scm (ghc-exception-transformers): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 10a52c0586..28c2dacad8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12634,6 +12634,28 @@ transformers 0.2 or 0.3 compatibility to run on old versions of the platform,
but also need those types.")
(license license:bsd-3)))
+(define-public ghc-exception-transformers
+ (package
+ (name "ghc-exception-transformers")
+ (version "0.4.0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "exception-transformers" version))
+ (sha256
+ (base32
+ "1zmd2s40m86c9mhv32l5bvvf5r52cgpxvb4v5phyc3pjwlr7m8g5"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "exception-transformers")))
+ (inputs (list ghc-fail ghc-transformers-compat))
+ (native-inputs (list ghc-hunit ghc-test-framework ghc-test-framework-hunit))
+ (home-page "http://hackage.haskell.org/package/exception-transformers")
+ (synopsis "Type classes and monads for unchecked extensible exceptions")
+ (description
+ "This package provides type classes, a monad and a monad transformer that support
+unchecked extensible exceptions as well as asynchronous exceptions. It is
+compatible with the transformers package.")
+ (license license:bsd-3)))
+
(define-public ghc-tree-diff
(package
(name "ghc-tree-diff")