aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-21 18:11:10 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-21 18:11:30 -0500
commit8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a (patch)
tree0e0f0cc9d5fa5a3c783451d12b10ebdb4c0aafe9 /gnu/packages/haskell-xyz.scm
parentd1b786fe629ae9a80f37f64fdf48b9d7c132cd11 (diff)
parent42be8fa560a7554ac35801b46c3a0a007fd742ce (diff)
downloadguix-8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a.tar
guix-8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a.tar.gz
Merge branch 'master' into mesa-updates
Change-Id: I94c6874e5fdf916e3eb911f1a7df610cd3275474
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 676cdfa912..5d9e5757a0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3913,6 +3913,27 @@ when used with GHC versions which already provide the
(description "This library provides a fast logging system for Haskell.")
(license license:bsd-3)))
+(define-public ghc-fdo-notify
+ (package
+ (name "ghc-fdo-notify")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "fdo-notify" version))
+ (sha256
+ (base32 "1n4zk1i7g34w0wk5zy8n4r63xbglxf62h8j78kv5fc2yn95l30vh"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "fdo-notify")))
+ (inputs (list ghc-dbus))
+ (home-page "http://bitbucket.org/taejo/fdo-notify/")
+ (synopsis "Desktop Notifications client")
+ (description
+ "This package provides a library for issuing notifications using
+@code{FreeDesktop.org's} Desktop Notifications protcol. This protocol is
+supported by services such as Ubuntu's @code{NotifyOSD}.")
+ (license license:bsd-3)))
+
(define-public ghc-feed
(package
(name "ghc-feed")
@@ -15683,6 +15704,25 @@ purposes. See the
<https://www.stackage.org/package/githash>")
(license license:bsd-3)))
+(define-public ghc-git-lfs
+ (package
+ (name "ghc-git-lfs")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "git-lfs" version))
+ (sha256
+ (base32 "1iv3s1c7gwmsima9z3rsphjligpnf7h3vc5c96zgq9b71cx81lba"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "git-lfs")))
+ (inputs (list ghc-http-client ghc-http-types ghc-aeson ghc-network-uri
+ ghc-case-insensitive))
+ (home-page "http://hackage.haskell.org/package/git-lfs")
+ (synopsis "git-lfs protocol")
+ (description "An implementation of the git-lfs protocol.")
+ (license license:agpl3)))
+
(define-public ghc-nothunks
(package
(name "ghc-nothunks")