aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:54 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:23 +0200
commit584cc466efdb27256e5f062e91e72da63d83921f (patch)
treedd84740cd0bde0990ea7264d6341ca28ace7e224 /gnu/packages/haskell-xyz.scm
parent87bf63df6b77d4b97f3c3350968d8da7a3884c6a (diff)
downloadguix-584cc466efdb27256e5f062e91e72da63d83921f.tar
guix-584cc466efdb27256e5f062e91e72da63d83921f.tar.gz
gnu: Add ghc-prim-uniq.
* gnu/packages/haskell-xyz.scm (ghc-prim-uniq): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 55893404a6..11f8711cdf 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16564,6 +16564,26 @@ same-and-increasingly-sized values.")
to incorporate LeanCheck tests into test-framework test suites.")
(license license:bsd-3)))
+(define-public ghc-prim-uniq
+ (package
+ (name "ghc-prim-uniq")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "prim-uniq" version))
+ (sha256
+ (base32
+ "1l7jlv3pfasn89n2wpgff972npy423vqsidkkn5crxfyqjyzxbdv"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "prim-uniq")))
+ (inputs (list ghc-dependent-sum ghc-primitive))
+ (home-page "https://github.com/obsidiansystems/prim-uniq")
+ (synopsis "Opaque unique identifiers in primitive state monads")
+ (description
+ "This library provides opaque unique identifiers in primitive state
+monads and a GADT-like type using them as witnesses of type equality.")
+ (license license:public-domain)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar