aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit08ae5d53e8dd79cec9df2cdfe382618f22fad48f (patch)
treed1614b5ce8487f2ee21109270b60044bbd65e29f /gnu/packages/haskell-xyz.scm
parenta4706eef32d6d79dd3f9b2b457410c06e4f63633 (diff)
downloadguix-08ae5d53e8dd79cec9df2cdfe382618f22fad48f.tar
guix-08ae5d53e8dd79cec9df2cdfe382618f22fad48f.tar.gz
gnu: Add ghc-irc-core.
* gnu/packages/haskell-xyz.scm (ghc-irc-core): New public variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7d01da6739..1db3a157f1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6172,6 +6172,32 @@ Jupyter notebooks, along with @code{ToJSON} and @code{FromJSON}
instances for conversion to and from JSON .ipynb files.")
(license license:bsd-3)))
+(define-public ghc-irc-core
+ (package
+ (name "ghc-irc-core")
+ (version "2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "irc-core" version))
+ (sha256
+ (base32 "13jkfb30kynqd55c2slxjg98lr076rn1ymsxniwp0bssjzizgnfc"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ (list ghc-hunit))
+ (inputs
+ (list ghc-base64-bytestring
+ ghc-attoparsec
+ ghc-hashable
+ ghc-primitive ghc-vector))
+ (properties '((upstream-name . "irc-core")))
+ (home-page "https://github.com/glguy/irc-core")
+ (synopsis "IRC core library for glirc")
+ (description
+ "This is the IRC core library for glirc. The client is available in its own
+glirc package.")
+ (license license:isc)))
+
(define-public ghc-iwlib
(package
(name "ghc-iwlib")