aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit2324db2aba2d9601ba5d4a8bfb4e28b4e3e94a57 (patch)
tree9956790538154c82ccd9674413fedbd27d362da8 /gnu/packages/haskell-crypto.scm
parent9bab4f41248985885cff252fe8eb7cb4771bb237 (diff)
downloadguix-2324db2aba2d9601ba5d4a8bfb4e28b4e3e94a57.tar
guix-2324db2aba2d9601ba5d4a8bfb4e28b4e3e94a57.tar.gz
gnu: Add ghc-tls-1.9.
* gnu/packages/haskell-crypto.scm (ghc-tls-1.9): New variable. Change-Id: I53d26e85d7ed333be036cb5e0e359b72f5c21262
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 0198c57272..ce53b0f122 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -859,6 +859,43 @@ Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
extensions.")
(license license:bsd-3)))
+(define-public ghc-tls-1.9
+ (package
+ (name "ghc-tls")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tls" version))
+ (sha256
+ (base32 "0gj3af9sqd0bw7dpcqfyvbslpxsk2ij00a77kl710fwhw35vj1an"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "tls")))
+ (inputs (list ghc-cereal
+ ghc-data-default-class
+ ghc-memory
+ ghc-crypton
+ ghc-asn1-types
+ ghc-asn1-encoding
+ ghc-crypton-x509
+ ghc-crypton-x509-store
+ ghc-crypton-x509-validation
+ ghc-async
+ ghc-unix-time
+ ghc-network))
+ (native-inputs (list ghc-tasty ghc-tasty-quickcheck ghc-quickcheck))
+ (home-page "http://github.com/vincenthz/hs-tls")
+ (synopsis "TLS/SSL protocol native implementation (Server and Client)")
+ (description
+ "Native Haskell TLS and SSL protocol implementation for server and client.
+This provides a high-level implementation of a sensitive security protocol,
+eliminating a common set of security issues through the use of the advanced
+type system, high level constructions and common Haskell features. Currently
+implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
+Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
+extensions.")
+ (license license:bsd-3)))
+
(define-public ghc-hsopenssl
(package
(name "ghc-hsopenssl")