aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2023-01-09 18:06:10 -0500
committerDavid Thompson <dthompson2@worcester.edu>2023-01-18 09:21:12 -0500
commit323d868ceb0eb6451d86f8ff0a7a0aa20c3cfd00 (patch)
tree854e8037bafaa5943ae03641fc396cfc8eb1f0be /gnu/packages/haskell-apps.scm
parent8bf8b59101d774dfd991e3c9ddc40dcddc1288bd (diff)
downloadguix-323d868ceb0eb6451d86f8ff0a7a0aa20c3cfd00.tar
guix-323d868ceb0eb6451d86f8ff0a7a0aa20c3cfd00.tar.gz
gnu: git-annex: Patch 'git-annex webapp' to use hardcoded lsof.
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Substitute "lsof" in 'patch-webapp' phase. [inputs]: Add lsof.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 4ac486eeb6..9cb383eeb2 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-web)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages lsof)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -335,7 +336,11 @@ to @code{cabal repl}).")
;; webapp' runs without making the user also install xdg-utils.
(substitute* '("Assistant/WebApp/DashBoard.hs"
"Utility/WebApp.hs")
- (("xdg-open") (which "xdg-open")))))
+ (("xdg-open") (which "xdg-open")))
+ ;; Also replace loose references to lsof.
+ (substitute* "Assistant/Threads/Watcher.hs"
+ (("\"lsof\"")
+ (string-append "\"" (which "lsof") "\"")))))
(add-before 'configure 'factor-setup
(lambda _
;; Factor out necessary build logic from the provided
@@ -480,6 +485,7 @@ to @code{cabal repl}).")
ghc-yesod-core
ghc-yesod-form
ghc-yesod-static
+ lsof
rsync
xdg-utils))
(propagated-inputs