aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-11-09 23:07:18 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2023-11-12 23:23:20 +0100
commit77386bdbfe6b0c649c05ab37f08051d1ab3e5074 (patch)
treed904eb520b92c5303d151ca025708ddf507c9e00 /gnu/packages/hardware.scm
parent978f4a9dc4c09d12383561d7ae7ab3441c744ebd (diff)
downloadguix-77386bdbfe6b0c649c05ab37f08051d1ab3e5074.tar
guix-77386bdbfe6b0c649c05ab37f08051d1ab3e5074.tar.gz
gnu: openrgb: Fix up chmod invocations inside udev rules.
* gnu/packages/hardware.scm (openrgb)[arguments]<#:phases>[patch-chmod]: New phase. Change-Id: Ib82a8cc42a896aaf9dc7ea0ff36a3c259f9a26af
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e1514fb40b..0652e2933d 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1089,11 +1089,17 @@ technology, such as head mounted displays with built in head tracking.")
(("dependencies/json")
(string-append #$(this-package-input "nlohmann-json")
"/include/nlohmann")))))
+ (add-after 'unpack 'patch-chmod
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "scripts/build-udev-rules.sh"
+ (("/bin/chmod") (string-append (assoc-ref inputs "coreutils")
+ "/bin/chmod")))))
;; Call qmake instead of configure to create a Makefile.
(replace 'configure
(lambda _ (invoke "qmake" "PREFIX=/" "OpenRGB.pro"))))))
(inputs
- (list hidapi
+ (list coreutils
+ hidapi
hueplusplus
nlohmann-json
libusb