aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:06 +0200
commit634f7cd7dfef8746a39c2054d0ef9240a75d74d1 (patch)
treeadb5a193e448e946715d776426cbf3975cfe0195 /gnu/packages/hardware.scm
parente940828ccf85b4c8c84c8e3ee65b626cee8c0396 (diff)
downloadguix-634f7cd7dfef8746a39c2054d0ef9240a75d74d1.tar
guix-634f7cd7dfef8746a39c2054d0ef9240a75d74d1.tar.gz
gnu: memtest86+: Use G-expressions.
* gnu/packages/hardware.scm (memtest86+)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e3d6df23b5..50ad9ff15f 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -811,27 +811,29 @@ specific SMBIOS tables.")
(base32 "0fv605blaf4z0jyl1wp37x5x014dkp0z0a0fh114ws62fhnhdnlv"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no way to test this
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'build 'enter-build-directory
- (lambda _
- (chdir ,(if (target-x86-32?)
- "build32"
- "build64"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/memtest86+"))
- (doc (string-append out "/share/doc/memtest86+-" ,version)))
- (for-each
- (lambda (file)
- (install-file file lib))
- (list "memtest.bin"
- "memtest.efi"))
- (chdir "..")
- (install-file "README.md" doc)))))))
+ (list
+ #:tests? #f ; no way to test this
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'build 'enter-build-directory
+ (lambda _
+ (chdir #$(if (target-x86-32?)
+ "build32"
+ "build64"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/memtest86+"))
+ (doc (string-append out "/share/doc/memtest86+-"
+ #$version)))
+ (for-each
+ (lambda (file)
+ (install-file file lib))
+ (list "memtest.bin"
+ "memtest.efi"))
+ (chdir "..")
+ (install-file "README.md" doc)))))))
(supported-systems (list "i686-linux" "x86_64-linux"))
(home-page "https://www.memtest.org/")
(synopsis "Thorough real-mode memory tester")