aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-01 10:46:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-01 10:46:34 +0200
commit26744bca203eb481f3ad2931165757d43b839aa6 (patch)
treee548c883d0876da2b33ee66eeb3d2ac61f7d9c76 /gnu/packages/hardware.scm
parentf726d2fd0708395bbe70b97cd724f86a21055524 (diff)
downloadguix-26744bca203eb481f3ad2931165757d43b839aa6.tar
guix-26744bca203eb481f3ad2931165757d43b839aa6.tar.gz
gnu: openrgb: Unbundle more libraries.
* gnu/packages/hardware.scm (openrgb)[source]: Adjust snippet to remove more bundled dependencies.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 9da2b4ad29..65558ffe08 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1013,9 +1013,19 @@ technology, such as head mounted displays with built in head tracking.")
(modules '((guix build utils)))
(snippet
'(begin
- ;; Delete the bundled hueplusplus and json libraries.
- (delete-file-recursively "dependencies/hueplusplus-1.0.0")
- (delete-file-recursively "dependencies/json")))))
+ ;; Delete many of the bundled libraries.
+ (for-each delete-file-recursively
+ (list "dependencies/hidapi-win"
+ "dependencies/hueplusplus-1.0.0"
+ "dependencies/json"
+ "dependencies/libusb-1.0.22"
+ "dependencies/macUSPCIO"
+ "dependencies/mbedtls-2.24.0"
+ "dependencies/NVFC"
+ "dependencies/openrazer-win32"
+ "dependencies/winring0"
+ ;; Some bundled appimages
+ "scripts/tools"))))))
(build-system cmake-build-system)
(arguments
(list