aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorFelix Lechner via Guix-patches via <guix-patches@gnu.org>2023-05-21 23:27:36 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 10:38:03 +0200
commit244baa607dd98746498f4599d5f4a6e278dab502 (patch)
tree5fe4c2f2146c4b63ab6f85c384a2e141f84844cb /gnu/packages/hardware.scm
parent89e1c976828aba167a0cbfd60a9d295a66a6517d (diff)
downloadguix-244baa607dd98746498f4599d5f4a6e278dab502.tar
guix-244baa607dd98746498f4599d5f4a6e278dab502.tar.gz
gnu: tpm2-tools: New variable
* gnu/packages/hardware.scm (tpm-tools): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index c23299d1db..17c1556ecd 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages high-availability)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -1313,6 +1314,37 @@ libtss2-esys, libtss2-sys, libtss2-mu, libtss2-tcti-device, libtss2-tcti-swtpm
and libtss2-tcti-mssim.")
(license license:bsd-2)))
+(define-public tpm2-tools
+ (package
+ (name "tpm2-tools")
+ (version "5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tpm2-software/tpm2-tools/"
+ "releases/download/" version "/"
+ "tpm2-tools-" version ".tar.gz"))
+ (sha256
+ (base32 "08y16q92dh7frsyw0zlm3q9gsfqyls0li248s2pgsysk633lknqz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ curl
+ libtool
+ gnu-gettext
+ openssl
+ pandoc
+ pkg-config
+ tpm2-tss))
+ (home-page "https://github.com/tpm2-software/tpm2-tools")
+ (synopsis "Tools for the Trusted Platform Module (TPM 2.0)")
+ (description
+ "This package provides user tools for the Trusted Computing Group's (TCG)
+TPM2 Software Stack (TSS). These programs help with common tasks such as key
+management, attestation, encryption, and signing.")
+ (license license:bsd-3)))
+
(define-public libcpuid
;; We need to remove blobs from the source, first we have to isolate the blob
;; source in build system.