aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-17 14:56:30 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-24 13:39:05 +0000
commite970e9149d4e327fd72e6b40f93fa9f8c2c09c07 (patch)
treece6a12cdc10acd69580a61e29c806de670e68a62 /gnu/packages/guile.scm
parent34f2d3aad7009955bd426b0dfd6ce62c64fff458 (diff)
downloadguix-e970e9149d4e327fd72e6b40f93fa9f8c2c09c07.tar
guix-e970e9149d4e327fd72e6b40f93fa9f8c2c09c07.tar.gz
gnu: guile-3.0-latest: Add patch for invalid unicode handling.
This patch fixes handling of invalid unicode when using suspendable ports. Reported upstream at https://debbugs.gnu.org/cgi/bugreport.cgi?bug=62290 and patch merged as cba2e7e3fec3c781230570f5d1ef070625eeeda8. As the build coordinator agents use suspendable ports, this will fix issues with building things where the log output contains invalid unicode. * gnu/packages/patches/guile-fix-invalid-unicode-handling.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/guile.scm (guile-3.0-latest)[source]: Use it. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 2fd9b711ce..b6db506140 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -398,7 +398,9 @@ without requiring the source code to be rewritten.")
version ".tar.xz"))
(sha256
(base32
- "03bm1mnfc9kkg2ls942a0js7bxrdzmcffgrgg6anwdmjfan2a9hs"))))
+ "03bm1mnfc9kkg2ls942a0js7bxrdzmcffgrgg6anwdmjfan2a9hs"))
+ (patches (search-patches
+ "guile-fix-invalid-unicode-handling.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments guile-3.0)
;; Guile 3.0.9 is bit-reproducible when built in parallel, thanks to