aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-13 18:50:22 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:37 +0200
commitc4c08775a820868059b59c68d4dfd6be0c9d9010 (patch)
tree1ce4ca7f64e2c130dd7aa216601c28275b25a0f5 /gnu/packages/guile.scm
parent10059113431fc6fdbcd94351e14881af5dda907c (diff)
downloadguix-c4c08775a820868059b59c68d4dfd6be0c9d9010.tar
guix-c4c08775a820868059b59c68d4dfd6be0c9d9010.tar.gz
gnu: guile-2.0: Skip failing tests on the Hurd.
* gnu/packages/guile.scm (guile-2.0)[arguments]: When building natively on the Hurd, add stage 'disable-threads.tests'... (guile-2.2): ...and when building natively on the Hurd, delete it again.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 64a1b900de..1d36e3ee2a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -212,8 +212,13 @@ without requiring the source code to be rewritten.")
(rename-file "test-suite/tests/srfi-18.test" "srfi-18.test")
;; failed to remove 't-guild-compile-7215.go.tdL7yC
(substitute* "test-suite/standalone/Makefile.in"
- (("test-guild-compile ") ""))
- #t)))
+ (("test-guild-compile ") "")))))
+ '())
+ ,@(if (system-hurd?)
+ '((add-after 'unpack 'disable-threads.tests
+ (lambda _
+ ;; Many tests hang, esp. (join-thread ..), also others.
+ (rename-file "test-suite/tests/threads.test" "threads.test"))))
'())
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
@@ -286,7 +291,12 @@ without requiring the source code to be rewritten.")
(if (target-x86-32?) ;<https://issues.guix.gnu.org/49368>
`(append '("--disable-static")
'("CFLAGS=-g -O2 -fexcess-precision=standard"))
- flags))))
+ flags))
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ #$@(if (system-hurd?)
+ #~((delete 'disable-threads.tests))
+ '())))))
(properties '((timeout . 72000) ;20 hours
(max-silent-time . 36000))) ;10 hours (needed on ARM