aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-18 11:55:51 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-19 17:54:48 +0100
commit75b7082bdf1ef1de9d4e2a0786120f051e7fffbd (patch)
tree8236aa44f56e6f64fd41c6e9dc43ce8f69753f1b /gnu/packages/guile.scm
parent26bb41d6d503a62e86b853774f6d8313abef2123 (diff)
downloadguix-75b7082bdf1ef1de9d4e2a0786120f051e7fffbd.tar
guix-75b7082bdf1ef1de9d4e2a0786120f051e7fffbd.tar.gz
gnu: guile-next: Add '.tarball-version' file to get correct version.
So far, "guile --version" and 'guile-3.0.pc' would use "UNKNOWN" as the version string, making the package unsuitable as a drop-in replacement for the 'guile-3.0' package. * gnu/packages/guile.scm (guile-next)[arguments]: Add 'set-version' phase.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index a0ed572cc0..9148c1075a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -453,6 +453,16 @@ without requiring the source code to be rewritten.")
(substitute-keyword-arguments (package-arguments guile-3.0)
((#:phases phases '%standard-phases)
`(modify-phases ,phases
+ (add-before 'bootstrap 'set-version
+ (lambda _
+ ;; Tell 'git-version-gen' what version this is, or it will
+ ;; just pick "UNKNOWN", making it unusable as a replacement
+ ;; for 'guile-3.0'. XXX: This is inaccurate when using
+ ;; '--with-branch' but using (package-version this-package)
+ ;; wouldn't give us a valid version string.
+ (call-with-output-file ".tarball-version"
+ (lambda (port)
+ (display ,version port)))))
(add-before 'check 'skip-failing-tests
(lambda _
(substitute* "test-suite/standalone/test-out-of-memory"