aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-28 17:42:32 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-02 21:40:35 +0100
commit5222ed8dc364f13a36bca13c151856a3edab795a (patch)
treed4288270ee5f9e5764b3da76dd06f116f83d73ac /gnu/packages/guile.scm
parent7df09ee0ab3e7962ef27859ce87e06a323059284 (diff)
downloadguix-5222ed8dc364f13a36bca13c151856a3edab795a.tar
guix-5222ed8dc364f13a36bca13c151856a3edab795a.tar.gz
gnu: libgc: Update to 8.2.2 and remove '--disable-munmap'.
* gnu/packages/bdw-gc.scm (libgc): Update to 8.2.2. [arguments]: Remove "--disable-munmap" from #:configure-flags. * gnu/packages/guile.scm (guile-3.0)[source]: Leave 'test-out-of-memory' test untouched. (guile-next)[arguments]: Likewise, in 'skip-failing-tests' phase. (guile-for-guile-emacs)[arguments]: Likewise, in 'bootstrap' phase.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 32faa8c020..d1b8f70f47 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -325,11 +325,8 @@ without requiring the source code to be rewritten.")
(patches '())
;; Replace the snippet because the oom-test still
;; fails on some 32-bit architectures.
- (snippet '(begin
- (substitute* "test-suite/standalone/Makefile.in"
- (("test-out-of-memory") ""))
- (for-each delete-file
- (find-files "prebuilt" "\\.go$"))))))
+ (snippet '(for-each delete-file
+ (find-files "prebuilt" "\\.go$")))))
;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>.
@@ -448,10 +445,7 @@ without requiring the source code to be rewritten.")
(display ,version port)))))
(add-before 'check 'skip-failing-tests
(lambda _
- (substitute* "test-suite/standalone/test-out-of-memory"
- (("!#") "!#\n\n(exit 77)\n"))
- (delete-file "test-suite/tests/version.test")
- #t))))))
+ (delete-file "test-suite/tests/version.test")))))))
(native-inputs
(modify-inputs (package-native-inputs guile-3.0)
(prepend autoconf
@@ -575,10 +569,6 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(substitute* "test-suite/tests/version.test"
(("\\(pass-if \"version reporting works\"" m)
(string-append "#;" m)))
- ;; Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
- ;; FAIL: test-out-of-memory
- (substitute* "test-suite/standalone/Makefile.am"
- (("(check_SCRIPTS|TESTS) \\+= test-out-of-memory") ""))
(patch-shebang "build-aux/git-version-gen")
(invoke "sh" "autogen.sh")