aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-11 12:35:50 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:34 +0200
commit69142dbea4eb5148ed165b494cae0ad730bf5514 (patch)
tree45067c64fc3972b270deedc0f53bc74dc9a1e68c /gnu/packages/gtk.scm
parent784610d6d65bfb827e173ae087f2a902f5f80cee (diff)
downloadguix-69142dbea4eb5148ed165b494cae0ad730bf5514.tar
guix-69142dbea4eb5148ed165b494cae0ad730bf5514.tar.gz
gnu: cairo: Support building for the Hurd.
Gobject-introspection and libdrm does not build for the Hurd. Poppler depends on nss, which does not build for the Hurd. * gnu/packages/gtk.scm (cairo)[native-inputs]: When building for the Hurd, do not include gobject-introspection. [inputs]: Likewise, do not include libdrm, poppler.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8e9a9dc8b2..c5ec7bcdc2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -194,15 +195,21 @@ such as mate-panel and xfce4-panel.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(,@(if (target-hurd?)
+ '()
+ `(("gobject-introspection" ,gobject-introspection)))
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
`(("bash-minimal" ,bash-minimal) ;for glib-or-gtk-wrap
- ("drm" ,libdrm)
+ ,@(if (target-hurd?)
+ '()
+ `(("drm" ,libdrm)))
("ghostscript" ,ghostscript)
("libspectre" ,libspectre)
- ("poppler" ,poppler)))
+ ,@(if (target-hurd?)
+ '()
+ `(("poppler" ,poppler)))))
(propagated-inputs
`( ;; ("cogl" ,cogl)
;; ("directfb" ,directfb)