aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 14:26:02 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:36:46 +0200
commitf14a1978111eec29934be3e375b46a739a8f48ee (patch)
tree7e0a6ef89ed41cf02a0544137505bf82bbed6036 /gnu/packages/groovy.scm
parent19ff61f4a58ac18be27b319ed46c862493ad321f (diff)
downloadguix-f14a1978111eec29934be3e375b46a739a8f48ee.tar
guix-f14a1978111eec29934be3e375b46a739a8f48ee.tar.gz
gnu: Add groovy-groovydoc.
* gnu/packages/groovy.scm (groovy-groovydoc): New variable.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index 520181c9c8..dee187ec3e 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -335,3 +335,44 @@ other groovy submodules.")))
(description "This package contains a template framework which is
well-suited to applications where the text to be generated follows the form of
a static template.")))
+
+(define groovy-groovydoc
+ (package
+ (inherit groovy-bootstrap)
+ (name "groovy-groovydoc")
+ (arguments
+ `(#:jar-name "groovy-groovydoc.jar"
+ #:jdk ,icedtea-8
+ #:test-dir "subprojects/groovy-groovydoc/src/test"
+ #:tests? #f; Requires groovy-ant which is a circular dependency
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "subprojects/groovy-groovydoc/src/main/resources"
+ "build/classes")
+ #t))
+ (replace 'build
+ (lambda _
+ (mkdir-p "build/classes")
+ (mkdir-p "build/jar")
+ (apply invoke "java" "-cp" (getenv "CLASSPATH")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/classes"
+ "-j"; joint compilation
+ (find-files "subprojects/groovy-groovydoc/src/main"
+ ".*\\.(groovy|java)$"))
+ (invoke "jar" "-cf" "build/jar/groovy-groovydoc.jar"
+ "-C" "build/classes" ".")
+ #t)))))
+ (inputs
+ `(("groovy-templates" ,groovy-templates)
+ ,@(package-inputs groovy-bootstrap)))
+ (native-inputs
+ `(("groovy-bootstrap" ,groovy-bootstrap)
+ ("groovy-test" ,groovy-test)
+ ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+ ,@(package-native-inputs java-groovy-bootstrap)))
+ (synopsis "Groovy documentation generation")
+ (description "This package contains the groovy documentation generator,
+similar to javadoc.")))