aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:22:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:43:02 +0300
commitee8cdd3b58a00f0285cb1ac304c930c9311ce923 (patch)
treec69ba48bb8682280854667895f22d02635bb5ffd /gnu/packages/graphics.scm
parent7ba92bd38fbcc622d33e853600adaa6343ecdf8b (diff)
downloadguix-ee8cdd3b58a00f0285cb1ac304c930c9311ce923.tar
guix-ee8cdd3b58a00f0285cb1ac304c930c9311ce923.tar.gz
gnu: imath: Skip tests when cross-compiling.
* gnu/packages/graphics.scm (imath)[arguments]: Adjust #:tests? to skip tests when cross-compiling.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 236b92d023..85e7b03a33 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -824,7 +824,8 @@ many more.")
;; precision), as was discussed and patched long ago:
;; <https://issues.guix.gnu.org/22049>. It seems the relevant fixes
;; didn't make it upstream, so skip tests.
- (list #:tests? (not (target-x86-32?))))
+ (list #:tests? (not (or (target-x86-32?)
+ (%current-target-system)))))
(home-page "https://github.com/AcademySoftwareFoundation/Imath")
(synopsis "Library of math operations for computer graphics")
(description