aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-14 07:46:15 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-14 07:46:15 +0200
commitd67507cacf934b970f67567bced4e044c3ca9753 (patch)
treeb1c3160946ceaf74a9a24c7360d28036230210e1 /gnu/packages/graphics.scm
parent3b3d9a13dd2bd67f34c890047680a1ce6e3af28e (diff)
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
downloadguix-d67507cacf934b970f67567bced4e044c3ca9753.tar
guix-d67507cacf934b970f67567bced4e044c3ca9753.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm42
1 files changed, 35 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 88b3b8c631..7e3e9e1702 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
@@ -824,7 +824,8 @@ many more.")
;; precision), as was discussed and patched long ago:
;; <https://issues.guix.gnu.org/22049>. It seems the relevant fixes
;; didn't make it upstream, so skip tests.
- (list #:tests? (not (target-x86-32?))))
+ (list #:tests? (not (or (target-x86-32?)
+ (%current-target-system)))))
(home-page "https://github.com/AcademySoftwareFoundation/Imath")
(synopsis "Library of math operations for computer graphics")
(description
@@ -2395,7 +2396,7 @@ generated discrete signed distance field using the cubic spline kernel.
(define-public mmg
(package
(name "mmg")
- (version "5.6.0")
+ (version "5.7.1")
(source
(origin
(method git-fetch)
@@ -2404,7 +2405,7 @@ generated discrete signed distance field using the cubic spline kernel.
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "173biz5skbwg27i5w6layg7mydjzv3rmi1ywhra4rx9rjf5c0cc5"))))
+ (base32 "0skb7yzsw6y44zp9gb729i5xks7qd97nvn3z6jhz4jksqksx7lz0"))))
(build-system cmake-build-system)
(outputs '("out" "lib" "doc"))
(arguments
@@ -2414,11 +2415,14 @@ generated discrete signed distance field using the cubic spline kernel.
;; The build doesn't honor -DCMAKE_INSTALL_BINDIR, hence
;; the adjust-bindir phase.
;;(string-append "-DCMAKE_INSTALL_BINDIR=" #$output "/bin")
+ (string-append "-DCMAKE_INSTALL_MANDIR=" #$output "/share/man")
"-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_DOC=ON"
"-DBUILD_TESTING=ON"
;; The longer tests are for continuous integration and
;; depend on input data which must be downloaded.
"-DONLY_VERY_SHORT_TESTS=ON"
+ "-DUSE_SCOTCH=ON"
;; TODO: Add Elas (from
;; https://github.com/ISCDtoolbox/LinearElasticity).
"-DUSE_ELAS=OFF"
@@ -2444,9 +2448,6 @@ generated discrete signed distance field using the cubic spline kernel.
(add-after 'install 'install-doc
(lambda _
(copy-recursively
- "../source/doc/man" (string-append #$output
- "/share/man/man1"))
- (copy-recursively
"doc" (string-append #$output:doc "/share/doc/"
#$name "-" #$version))))
(add-after 'install 'adjust-bindir
@@ -2496,6 +2497,33 @@ a tetrahedral mesh, isovalue discretization and Lagrangian movement;
@end itemize")
(license license:lgpl3+)))
+(define-public nanosvg
+ ;; There are no proper versions or releases; use the latest commit.
+ (let ((commit "9da543e8329fdd81b64eb48742d8ccb09377aed1")
+ (revision "0"))
+ (package
+ (name "nanosvg")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/memononen/nanosvg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pkzv75kavkhrbdd2kvq755jyr0vamgrfr7lc33dq3ipkzmqvs2l"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f ;no test suite
+ #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")))
+ (home-page "https://github.com/memononen/nanosvg")
+ (synopsis "Simple SVG parser")
+ (description "NanoSVG is a simple single-header SVG parser. The output
+of the parser is a list of cubic bezier shapes. The library suits well for
+anything from rendering scalable icons in an editor application to prototyping
+a game.")
+ (license license:zlib))))
+
(define-public f3d
(package
(name "f3d")