aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-25 15:10:56 -0300
committerVinicius Monego <monego@posteo.net>2024-04-06 08:00:59 -0300
commit81c6c8a01b91e65732f64afbb35980742441a5fd (patch)
treeaa3e6e4e00ac7b20f808a177928f3277d0a8bdd6 /gnu/packages/graphics.scm
parent38e93600b5cb62fd40d1c1b36ae7ca5c20718746 (diff)
downloadguix-81c6c8a01b91e65732f64afbb35980742441a5fd.tar
guix-81c6c8a01b91e65732f64afbb35980742441a5fd.tar.gz
gnu: openimageio: Update to 2.5.10.1.
* gnu/packages/graphics.scm (openimageio): Update to 2.5.10.1. [source]: Adjust tag prefix. [arguments]: Use G-Expressions. <#:configure-flags>: Pass "-DOIIO_BUILD_TESTS=false". [inputs]: Replace openexr-2 with openexr, fmt-8 with fmt. Use package labels. Sort alphabetically. Change-Id: I7016f89c5b7c78cbc1ffeac23e5c0cefe2a8f43b
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ad08141c96..591ca2b2a9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1313,40 +1313,38 @@ with strong support for multi-part, multi-channel use cases.")
(define-public openimageio
(package
(name "openimageio")
- (version "2.2.21.0")
+ (version "2.5.10.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/OpenImageIO/oiio")
- (commit (string-append "Release-" version))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0aicxbshzv1g9d8d08vsj1a9klaycxaifvvp565qjv70wyma2vkr"))))
+ "06x3lqj9qjh5m0zbr5g2g9ii6jk340pgzrhr4fb353y1y2pkx5sw"))))
(build-system cmake-build-system)
- ;; FIXME: To run all tests successfully, test image sets from multiple
- ;; third party sources have to be present. For details see
- ;; <https://github.com/OpenImageIO/oiio/blob/master/INSTALL.md>
(arguments
- `(#:tests? #f
- #:configure-flags (list "-DUSE_EXTERNAL_PUGIXML=1")))
+ (list #:tests? #f ; half the tests require online data or use redirection
+ #:configure-flags #~(list "-DUSE_EXTERNAL_PUGIXML=1"
+ "-DOIIO_BUILD_TESTS=false")))
(native-inputs
(list pkg-config))
(inputs
- `(("boost" ,boost)
- ("fmt" ,fmt-8)
- ("libheif" ,libheif)
- ("libpng" ,libpng)
- ("libjpeg" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("giflib" ,giflib)
- ("openexr" ,openexr-2)
- ("ilmbase" ,ilmbase)
- ("pugixml" ,pugixml)
- ("python" ,python-wrapper)
- ("pybind11" ,pybind11)
- ("robin-map" ,robin-map)
- ("zlib" ,zlib)))
+ (list boost
+ fmt
+ giflib
+ imath
+ libheif
+ libjpeg-turbo
+ libpng
+ libtiff
+ openexr
+ pugixml
+ pybind11
+ python-wrapper
+ robin-map
+ zlib))
(synopsis "C++ library for reading and writing images")
(description
"OpenImageIO is a library for reading and writing images, and a bunch of