aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-09 11:38:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-09 11:40:26 +0200
commit6e99158abb4441f6d2cd4c3176225204c505d657 (patch)
treeddfa6593b2a79da3e3b03a9a42c7843eff64cad9 /gnu/packages/graphics.scm
parent321979a15317eaf93b15e9cca30d328d39cca4b1 (diff)
downloadguix-6e99158abb4441f6d2cd4c3176225204c505d657.tar
guix-6e99158abb4441f6d2cd4c3176225204c505d657.tar.gz
gnu: povray: Drop input labels.
* gnu/packages/graphics.scm (povray)[inputs]: Remove all input labels. [arguments]: Use G-expression to avoid the use of %build-inputs.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9362666274..bdb67a93ef 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016, 2021, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2019, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2018, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -1525,32 +1525,32 @@ in Julia).")
(native-inputs
(list autoconf automake pkg-config))
(inputs
- `(("boost" ,boost)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("openexr" ,openexr-2)
- ("sdl" ,sdl)
- ("zlib" ,zlib)))
+ (list boost
+ libjpeg-turbo
+ libpng
+ libtiff
+ openexr-2
+ sdl
+ zlib))
(arguments
- '(#:configure-flags
- (list "COMPILED_BY=Guix"
- (string-append "--with-boost-libdir="
- (assoc-ref %build-inputs "boost") "/lib")
- "--disable-optimiz-arch")
+ (list
+ #:configure-flags
+ #~(list "COMPILED_BY=Guix"
+ (string-append "--with-boost-libdir="
+ #$(this-package-input "boost") "/lib")
+ "--disable-optimiz-arch")
#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'run-prebuild
- (lambda _
- (setenv "HOME" (getcwd))
- (with-directory-excursion "unix"
- (substitute* "prebuild.sh"
- (("/bin/sh") (which "sh")))
- (invoke "sh" "prebuild.sh"))
- #t))
- ;; The bootstrap script is run by the prebuild script in the
- ;; "run-prebuild" phase.
- (delete 'bootstrap))))
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'run-prebuild
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (with-directory-excursion "unix"
+ (substitute* "prebuild.sh"
+ (("/bin/sh") (which "sh")))
+ (invoke "sh" "prebuild.sh"))))
+ ;; The bootstrap script is run by the prebuild script in the
+ ;; "run-prebuild" phase.
+ (delete 'bootstrap))))
(synopsis "Tool for creating three-dimensional graphics")
(description
"@code{POV-Ray} is short for the Persistence of Vision Raytracer, a tool