aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-12 18:07:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-12 18:12:39 +0300
commit3fc26c6dc4b6bbf558a17b5e3ef8092ea0eeeacd (patch)
tree5310787d35622d8d6e14a916d6617400b2a71cf4 /gnu/packages/graphics.scm
parent0e21b01a9a982b77428c25b96661bb5108017e0d (diff)
downloadguix-3fc26c6dc4b6bbf558a17b5e3ef8092ea0eeeacd.tar
guix-3fc26c6dc4b6bbf558a17b5e3ef8092ea0eeeacd.tar.gz
gnu: directfb: Fix building on armhf-linux.
* gnu/packages/graphics.scm (directfb)[arguments]: Add a phase when building for armhf-linux to apply a patch. [native-inputs]: Add patch, patch file. * gnu/packages/patches/directfb-davinci-glibc-228-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 60db7543a6..bccfe89d55 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -189,13 +189,29 @@ framebuffer graphics, audio output and input event.")
(lambda _
(substitute* "src/core/core.c"
(("..BUILDTIME..") ""))))
+ ;; TODO: Move patch to source.
+ ,@(if (target-arm32?)
+ `((add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "patch" "--force" "-p1" "-i"
+ (assoc-ref inputs "patch-file")))))
+ '())
(add-after 'unpack 'disable-configure-during-bootstrap
(lambda _
(substitute* "autogen.sh"
(("^.*\\$srcdir/configure.*") ""))
#t)))))
(native-inputs
- (list autoconf automake libtool perl pkg-config))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ,@(if (target-arm32?)
+ `(("patch" ,patch)
+ ("patch-file"
+ ,(search-patch "directfb-davinci-glibc-228-compat.patch")))
+ '())))
(inputs
(list alsa-lib
ffmpeg