aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-03 09:09:58 -0300
committerVinicius Monego <monego@posteo.net>2024-04-06 08:40:56 -0300
commit12fd64c9f952189d82a8a6ba91f2178c479eb890 (patch)
treefa8cfd7704ba28919954d914e4f00ddbe91e6ebb /gnu/packages/graphics.scm
parentebaf658acd14b0fc37911007d9860e1f42837e5b (diff)
downloadguix-12fd64c9f952189d82a8a6ba91f2178c479eb890.tar
guix-12fd64c9f952189d82a8a6ba91f2178c479eb890.tar.gz
gnu: blender: Unbundle dependencies.
* gnu/packages/graphics.scm (blender)[arguments]<#:configure-flags>: Pass "-DWITH_SYSTEM_BULLET=ON", "-DWITH_SYSTEM_EIGEN3=ON", "-DWITH_SYSTEM_FREETYPE=ON", "-DWITH_SYSTEM_GLOG=ON", "-DWITH_SYSTEM_LZO=ON". [inputs]: Add bullet, eigen, glog, lzo. Change-Id: Iae52880a9fa3dc2a39948e5fe4fbddb84637c5da
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 05007c5818..a63629823a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -521,6 +522,11 @@ typically encountered in feature film production.")
"-DWITH_OPENVDB=ON"
"-DWITH_OPENSUBDIV=ON"
"-DWITH_PYTHON_INSTALL=OFF"
+ "-DWITH_SYSTEM_BULLET=ON"
+ "-DWITH_SYSTEM_EIGEN3=ON"
+ "-DWITH_SYSTEM_FREETYPE=ON"
+ "-DWITH_SYSTEM_GLOG=ON"
+ "-DWITH_SYSTEM_LZO=ON"
(string-append "-DPYTHON_LIBRARY=python" #$python-version)
(string-append "-DPYTHON_LIBPATH="
(assoc-ref %build-inputs "python")
@@ -539,11 +545,14 @@ typically encountered in feature film production.")
"/site-packages/")))))
(inputs
(list boost
+ bullet
+ eigen
embree
ffmpeg-5
fftw
freetype-with-brotli
glew
+ glog
gmp ;needed for boolean operations on meshes
imath
jack-1
@@ -556,6 +565,7 @@ typically encountered in feature film production.")
libx11
libxi
libxrender
+ lzo
openal
opencolorio
openexr