aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2022-03-27 15:26:08 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-23 16:24:46 +0200
commit5437c90953e679503c413552b2496e74e0c51fcf (patch)
treeae516a620e60a43b11f5aeba47389ff08d5b344e /gnu/packages/graph.scm
parent95b0544fcfa1a663435a9ac84db94312b938022b (diff)
downloadguix-5437c90953e679503c413552b2496e74e0c51fcf.tar
guix-5437c90953e679503c413552b2496e74e0c51fcf.tar.gz
gnu: python-plotly: Update to 5.6.0.
* gnu/packages/graph.scm (python-plotly): Update to 5.6.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 981c4d4793..6d1575a0bd 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -212,7 +212,7 @@ lines.")
(define-public python-plotly
(package
(name "python-plotly")
- (version "4.14.3")
+ (version "5.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -221,11 +221,15 @@ lines.")
(file-name (git-file-name name version))
(sha256
(base32
- "02wlgy7gf3v5ckiq9ab3prm53cckxkavlghqgkk9xw2sfmmrn61q"))))
+ "0kc9v5ampq2paw6sls6zdchvqvis7b1z8xhdvlhz5xxdr1vj5xnn"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'build 'skip-npm
+ ;; npm is not packaged so build without it
+ (lambda _
+ (setenv "SKIP_NPM" "T")))
(add-after 'unpack 'chdir
(lambda _
(chdir "packages/python/plotly")
@@ -247,6 +251,7 @@ lines.")
python-requests
python-retrying
python-six
+ python-tenacity
python-statsmodels))
(home-page "https://plotly.com/python/")
(synopsis "Interactive plotting library for Python")