aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 12:21:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:47 +0100
commit123c880fe94c0a75de9798fcc99129af59f23b8c (patch)
treeff2929187060aa8555184e481a2230fd0e498e41 /gnu/packages/graph.scm
parent6e835cd380c040aefbf38959634022417b29eb5b (diff)
downloadguix-123c880fe94c0a75de9798fcc99129af59f23b8c.tar
guix-123c880fe94c0a75de9798fcc99129af59f23b8c.tar.gz
gnu: Add python-pygsp.
* gnu/packages/graph.scm (python-pygsp): New variable. Change-Id: I8dd195216617e5cdb4a7453ecbe23cd9ff9e06a3
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 9dfe2efbc9..6411afd9e0 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -64,6 +64,7 @@
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
@@ -468,6 +469,43 @@ millions of nodes (as long as they can fit in memory). The core function is
algorithm for a number of different methods.")
(license license:gpl3+)))
+(define-public python-pygsp
+ (package
+ (name "python-pygsp")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyGSP" version))
+ (sha256
+ (base32 "002q4z3p3ka81rzhgi66qqmz1ccrg9hwch4bax7jsqixg64asx28"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; These all fail due to a type error in scipy.
+ '(list "-k" (string-append "not test_bunny"
+ " and not test_lowstretchtree"
+ " and not test_nngraph"
+ " and not test_plot_graphs"
+ " and not test_randomregular"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'disable-doctests
+ (lambda _
+ (substitute* "pygsp/tests/test_all.py"
+ (("def test_docstrings.*") "def _disabled_test_docstrings():\n")
+ (("return doctest.DocFileSuite.*") "return False\n")
+ (("suites.append\\(test_docstrings.*")
+ "")))))))
+ (propagated-inputs (list python-numpy python-scikit-image python-scipy))
+ (native-inputs (list python-coverage python-coveralls python-flake8))
+ (home-page "https://github.com/epfl-lts2/pygsp")
+ (synopsis "Graph Signal Processing in Python")
+ (description "The PyGSP is a Python package to ease signal processing on
+graphs.")
+ (license license:bsd-3)))
+
(define-public faiss
(package
(name "faiss")