aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-07-13 04:22:46 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-14 00:51:24 +0200
commitfd595f31e3301df7976951ceb9683e66f629c3dd (patch)
treea417939a9f224d275b28aa84e0786f92ce77559f /gnu/packages/golang.scm
parent4a28246d3080598d2f5b0a249607fc0ccbf81e83 (diff)
downloadguix-fd595f31e3301df7976951ceb9683e66f629c3dd.tar
guix-fd595f31e3301df7976951ceb9683e66f629c3dd.tar.gz
gnu: Add go-github-com-gologme-log.
* gnu/packages/golang.scm (go-github-com-gologme-log): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f76e49220a..bf99fd2d07 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5793,3 +5793,31 @@ inspired by the causal messaging system in the Pony programming language.")
(description "This package is a Go library that draws progress bars on
the terminal.")
(license license:bsd-3)))
+
+(define-public go-github-com-gologme-log
+ ;; this is the same as v1.2.0, only the LICENSE file changed
+ (let ((commit "720ba0b3ccf0a91bc6018c9967a2479f93f56a55"))
+ (package
+ (name "go-github-com-gologme-log")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gologme/log")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z3gs5ngv2jszp42ypp3ai0pn410v3b2m674g73ma7vsbn2yjk1n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gologme/log"))
+ (home-page "https://github.com/gologme/log/")
+ (synopsis
+ "Fork of the golang built in log package to add support for levels")
+ (description "This package is a drop in replacement for the built-in Go
+log package. All the functionality of the built-in package still exists and
+is unchanged. This package contains a series of small enhancements and
+additions.")
+ (license license:bsd-3))))