aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 22:40:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 22:48:29 +0100
commitab8f3b1612e209181256afac23c2eb6775498c3a (patch)
treefe81f5ed940b127ee0749a9ecc191728477b735e /gnu/packages/golang.scm
parent62b950a45d26c1708653aa45880390bbcb94f9c3 (diff)
downloadguix-ab8f3b1612e209181256afac23c2eb6775498c3a.tar
guix-ab8f3b1612e209181256afac23c2eb6775498c3a.tar.gz
gnu: go-github-com-libp2p-go-libp2p-metrics: Adjust inputs.
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-metrics): [propagated-inputs]: Swap from native-inputs to propagated-inputs to access them from dependent packages. Remove go-github-com-mr-tron-base58, go-github-com-gxed-hashland-keccakpg, go-github-com-minio-blake2b-simd, go-github-com-minio-sha256-simd, go-github-com-spaolacci-murmur3; and go-golang-org-x-crypto. Change-Id: I28b6da0ec96554052777cdba8971e831ef24df1b
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2a514a1ac..fb558c1b9c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4878,20 +4878,14 @@ required by Go's standard Hash interface.")
(build-system go-build-system)
(arguments
'(#:import-path "github.com/libp2p/go-libp2p-metrics"))
- (native-inputs
+ (propagated-inputs
(list go-github-com-libp2p-go-flow-metrics
go-github-com-libp2p-go-libp2p-peer
go-github-com-libp2p-go-libp2p-protocol
go-github-com-libp2p-go-libp2p-crypto
- go-github-com-mr-tron-base58
go-github-com-multiformats-go-multihash
go-github-com-btcsuite-btcd-btcec
- go-github-com-gogo-protobuf
- go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
+ go-github-com-gogo-protobuf))
(home-page "https://github.com/libp2p/go-libp2p-metrics")
(synopsis "Connection wrapper for go-libp2p that provides bandwidth metrics")
(description "A connection wrapper for @command{go-libp2p} that provides bandwidth