aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 17:44:46 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:16 +0000
commit82a9ceebe8cf3ed73345c6be42465865c9613f8c (patch)
treeb2e5fd3f8ae494096659b4effe6bd9456f65dbab /gnu/packages/golang.scm
parentd8b0ad79a897a40eb2344ffad8f6ac48753d373a (diff)
downloadguix-82a9ceebe8cf3ed73345c6be42465865c9613f8c.tar
guix-82a9ceebe8cf3ed73345c6be42465865c9613f8c.tar.gz
gnu: go-golang-org-x-time: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-time): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/high-availability.scm: Add (gnu packages golang-build) module. Change-Id: I2f2704501b19d991d153c6d8636e1f9fc4cf154b
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ca29596b4..63d54311b0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3587,37 +3587,6 @@ processing.")
(home-page "https://go.googlesource.com/text")
(license license:bsd-3)))
-(define-public go-golang-org-x-time
- (let ((commit "9d24e82272b4f38b78bc8cff74fa936d31ccd8ef")
- (revision "2"))
- (package
- (name "go-golang-org-x-time")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/time")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1f5nkr4vys2vbd8wrwyiq2f5wcaahhpxmia85d1gshcbqjqf8dkb"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "golang.org/x/time"
- ; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
-; (propagated-inputs
-; `(("go-golang-org-x-net" ,go-golang-org-x-net)))
- (synopsis "Supplemental Go time libraries")
- (description "This package provides supplemental Go libraries related to
-time.")
- (home-page "https://godoc.org/golang.org/x/time/rate")
- (license license:bsd-3))))
-
(define-public go-golang-org-x-oauth2
(let ((commit "0f29369cfe4552d0e4bcddc57cc75f4d7e672a33")
(revision "1"))